WordPress Gutenberg 10.2 Hatalar Neden Oluyor ?

WordPress Gutenberg 10.2
WordPress Gutenberg 10.2

WordPress Gutenberg 10.2 Hatalar Neden Oluyor ?, WordPress Gutenberg 10.2 ölümcül hataya neden oluyor Gutenberg 10.2 sürümüne güncellendiğinde, WordPress Hatalar, WordPress uyumluluk sorunları ölümcül hatalara neden olabilir.

WordPress Gutenberg 10.2 Hatalar Neden Oluyor ?
WordPress Gutenberg 10.2 Hatalar Neden Oluyor ?

WordPress yayıncıları, Gutenberg 10.2’nin (17 Mart 2021’de yayınlandı) WordPress uyumsuzluk sorunları nedeniyle “ölümcül bir hataya” neden olduğunu keşfettiler. Bir yayıncı, Gutenberg Otomatik Güncellemelerinin bir uyumluluk kontrolü çalıştırması ve bir uyumsuzluk varsa bir uyarı tetiklemesi gerektiğini önerdi. WordPress Hataları Neden Olur şimdi bu sorularınızın cevaplarını aşağıda sizlere vereceğiz.


Ayrıca şu Haberimizi de Okuyunuz: WordPress HTTP’den HTTPS Dönüştürme


WordPress Gutenberg 10.2

WordPress Gutenberg çekirdeğinde yerel olarak bir web sitesi oluşturma yönteminden temelde farklı olan görsel bir WordPress web sitesi editörüdür. Yayıncıların, modülün grafik kullanıcı arayüzünü kullanarak web siteleri oluşturmasına olanak tanır. Örneğin, bir web sayfası sayfanın üstünü (başlık), içerik alanını, kenar çubuğunu vb. Kaplayabilir. Temsili bir blok olarak görselleştirilebilir.

Gutenberg henüz bitmedi ve tam site düzenleme işlevi hala geliştirme aşamasındadır. Doğal olarak, beklenmiyorsa, olgunlaşmamış teknik arızalar da beklenebilir.

WordPress Hatalar

Gelişmiş WordPress Facebook grubunun üyeleri, Gutenberg 10.2’ye güncelleme yaparken karşılaşılan ölümcül hatayı belgelemek için bir tartışma başlattı.

Gönderi, önemli hatanın WordPress 5.6 sürümünde meydana geldiğini belirtti. Ayrıca GitHub yazısının hata ile ilgili olarak Gutenberg 10.2’nin de WP 5.5 ile uyumsuz olduğunu belirttiğine dikkat edilmelidir.

WordPress ve Gutenberg yayın programı

WordPress 5.7, 9 Mart 2021’de yayınlandı. Gutenberg 10.2 web sitesi editörü bir hafta sonra 17 Mart 2021’de yayınlandı. WordPress 5.7 ve Gutenberg 10.2’ye güncellenen Gutenberg web sitelerinin yayıncıları bu hatayı görmemelidir. Ancak, Gutenberg 10.2’ye güncelleme yapan ancak WordPress’in kendisi olmayan yayıncılar ölümcül hatalarla karşılaşabilir.

Ölümcül hataların, yayıncıların Gutenberg’in kurulumunu otomatik olarak güncellenmesini (otomatik güncellemeler) ayarlamasına, ancak WordPress’in kendisini otomatik olarak güncellememesine neden olması özellikle kolaydır.

Resmi Gutenberg WordPress destek forumunda bir hata bulundu, ancak bu makale yayınlandığında herhangi bir takip yapılmadı.

Ölümcül güvenlik açığı sorunu ayrıca resmi Gutenberg GitHub sayfasında da kaydedilmiştir.


Ayrıca şu Haberimizi de Okuyunuz: WordPress Internet Explorer


GitHub’dan rapor: “ 10.2.0’a güncelledikten sonra, eklentiyle ilgili teknik bir sorunla ilgili bir e-posta aldım: Dosyanın 59. satırında E_ERROR türünde bir hataya neden oldu … Eklentiyi ftp ile devre dışı bırakabildim. Şimdilik, bu sorunun çözüldüğünü bilmediğim sürece etkinleştirmek istemiyorum. “

Başka bir kişi de aynı şeyi fark ettiğini ve bir ekran görüntüsü paylaştığını bildirdi:

Ekran görüntüsünü gönderen kullanıcı şöyle söyledi:

“WordPress 5.6 çalıştırıyorum. 5.7’ye yükselttikten sonra, her şey beklendiği gibi çalışıyor.” GitHub gönderisini ilk gönderen kişi bunun da kendi sorunu olduğunu doğruladı.

“5.7’yi bilgilendirdiğiniz için teşekkür ederiz. WP’yi de güncellemedim. Artık Gutenberg’i yeniden etkinleştirebilirim.”

Gutenberg 10.2, WordPress’in eski sürümleriyle uyumlu değildir

WordPress Gutenberg GitHub Gutenberg’in bir başka raporu, Gutenberg 10.2’nin WordPress’in eski sürümlerinde ölümcül hatalara neden olduğunu vurguladı.

WordPress’in 5.5.3 sürümünü kullanan yayıncılar ayrıca çökmeye neden olan önemli bir hata bildirdi.

Sorunu bildiren kişi, sorunun Gutenberg 10.2’ye özgü olduğunu doğruladı ve şunları kaydetti:

“Gutenberg eklentisi 10.2.0’ı devre dışı bıraktım. Eklentiyi yeniden etkinleştirmeye çalıştığımda ölümcül bir hata oluştu.

Önemli hata: Yakalanmamış Hata: 'WP_Block_Supports' sınıfı bulunamadı ... "

Kişi yararlı bir gözlem ve öneride bulundu ve Gutenberg 10.2’nin WP 5.7’nin altındaki WordPress sürümlerinde güncellenmesine (veya otomatik olarak güncellenmesine) izin verilmediğini öne sürdü.

“Eski WP web sitesinde Gutenberg eklentisini otomatik olarak güncellemek imkansız olmalı. Sonuç ölümcül bir hata gibi görünüyor. Çünkü bu sorunu yaşayan birçok web sitesi olabilir.”

Bu, sorunu çözmenin iyi bir yoludur! Gutenberg 10.2 ile WordPress’in eski bir sürümü arasında bilinen bir uyumsuzluk varsa, bu durumda, otomatik güncelleme durur ve bir uyumsuzluk uyarısı oluşturur, bu da mantıklıdır. WP 5.7’den önce WordPress sürümleriyle yayınlanan Gutenberg site editörü kullanıcıları, Gutenberg 10.2’ye güncelleme yapmadan önce en son sürüme güncellemenin akıllıca olacağını düşünebilir.

WordPress Gutenberg 10.2 Hatalar Neden Oluyor ? için Daha Fazla Kaynak istiyor iseniz bizleri takip ediniz.

Yardıma ihtiyacınız olursa bizimle iletişime geçmek için “yorumlarda sorularınızı belirtin. WordPress Gutenberg 10.2 Sorunuzu da bu şekilde yanıtlamış oluruz. Bizleri sosyal medya adreslerimizden takip edebilirsiniz. Ayrıca Diğer WordPress Haberleri Bültenimize de Göz gezdirmenizi de İsteriz.


Ayrıca şu Haberimizi de Okuyunuz: WordPress Sorunları


Bu sitede kopyalama izin yok! Anlayışınız için teşekkürler.